Car starts, idles to almost nothing, then shuts off

Keep it on topic, it will make it easier to find what you need.

Moderator: So Cal Mark

Car starts, idles to almost nothing, then shuts off

Postby radionovember on Thu Oct 21, 2010 11:50 am

Last question and I think I'll have this thing is good shape. I'm not sure where to begin to troubleshoot this problem. I have an 82 Spider 2000 FI and when I crank it, about 30% of the time, it will crank and then idle immediately down to about 2 on the rpm gauge before dying. I can keep cranking and it will keep doing that unless I rev to about 10 and hold it for about 10 seconds or so. Then it will generally stay up and be fine for the drive. Any ideas what might cause that? It's not necessarily consistent but its regular enough for me to feel like it should be fixed. Thanks for the help...
User avatar
radionovember
 
Posts: 50
Joined: Sun Sep 05, 2010 1:10 am
Location: Nashville, TN

Re: Car starts, idles to almost nothing, then shuts off

Postby macawlover70 on Sat Oct 23, 2010 6:22 am

Try replacing the cold start valve. You can check it by removing it and it should spray for a few seconds when you turn the ignition key.
CARPE FIAT!
Robert Daniels
SouthTexas
81' F.I. Fiat Spider
Image
User avatar
macawlover70
 
Posts: 82
Joined: Sat Dec 12, 2009 5:15 pm
Location: Texas

Re: Car starts, idles to almost nothing, then shuts off

Postby 2ndwind on Sat Oct 23, 2010 3:13 pm

I know I am obsessed with the AFM but I suggest you check that the AFM door swings without catching.
Steve
1982 Red Spider 2000
1919 Old Town Sailing Canoe
2ndwind
 
Posts: 506
Joined: Tue Oct 27, 2009 9:17 pm
Location: Cincinnati OH

Re: Car starts, idles to almost nothing, then shuts off

Postby radionovember on Mon Oct 25, 2010 3:50 pm

Thanks guys... Ill check the cold start valve this week and if that seems to be fine, I'm going for the AFM. Here's to hoping I can get this thing back to running like new.
User avatar
radionovember
 
Posts: 50
Joined: Sun Sep 05, 2010 1:10 am
Location: Nashville, TN

Re: Car starts, idles to almost nothing, then shuts off

Postby majicwrench on Mon Oct 25, 2010 4:38 pm

It is almost certainly NOT the cold start valve. If CSV fails, car will be miserable hard to start at all. If car starts fine, just won't idle, it is NOT the CSV.
There is an idle air valve on the FI cars that needs to be open when cold. Is easy to check, just look inside cold and hole should not be blocked.
There are some wonderful troubleshooting info on the web somewhere for these. Check, test before replacing expesive parts.
majicwrench
 
Posts: 1801
Joined: Mon Sep 08, 2008 10:39 pm


Return to Engine and Tuning

Who is online

Users browsing this forum: No registered users and 2 guests